1 | notes " *** To complete the Xymon install *** |
---|
2 | |
---|
3 | |
---|
4 | 1) Tune the number of shared message queues |
---|
5 | ---------------------------------------------- |
---|
6 | |
---|
7 | Xymon server needs at least 9 IPC message queues to run. |
---|
8 | Unfortunately Mac OS X ships with a default max of 8. |
---|
9 | |
---|
10 | Check how much shared segments a process can use on |
---|
11 | your system: |
---|
12 | $ sysctl kern.sysv.shmseg |
---|
13 | And the max number of shared segments system-wide: |
---|
14 | $ sysctl kern.sysv.shmmni |
---|
15 | |
---|
16 | If the first number is < 9, you need to tune your system |
---|
17 | before trying to start xymon server (doing so will make |
---|
18 | the whole system to crash). |
---|
19 | |
---|
20 | Run the following commands to increase your shared |
---|
21 | segments: |
---|
22 | $ sudo echo \"kern.sysv.shmmni=64\" >> /etc/sysctl.conf |
---|
23 | $ sudo echo \"kern.sysv.shmseg=12\" >> /etc/sysctl.conf |
---|
24 | |
---|
25 | Reboot your system to activate the change. After reboot you can |
---|
26 | read these instructions with: |
---|
27 | $ cat ${prefix}/lib/xymon/INSTALL.macports.xymon.server |
---|
28 | |
---|
29 | More information about shared memory segments on Mac OS X |
---|
30 | can be found here: http://support.apple.com/kb/HT4022 |
---|
31 | |
---|
32 | |
---|
33 | |
---|
34 | 2) Configure your apache web server |
---|
35 | ---------------------------------------------- |
---|
36 | |
---|
37 | Xymon \"make install\" ends with: |
---|
38 | You must configure your webserver for the Hobbit webpages and CGI-scripts. |
---|
39 | A sample Apache configuration is in ${prefix}/lib/xymon/server/etc/hobbit-apache.conf |
---|
40 | If you have your Administration CGI scripts in a separate directory, |
---|
41 | then you must also setup the password-file with the htpasswd command. |
---|
42 | |
---|
43 | So the following commands should do it: |
---|
44 | $ sudo mv ${prefix}/lib/xymon/server/etc/hobbit-apache.conf /etc/apache2/sites/ |
---|
45 | $ sudo /usr/sbin/apachectl restart |
---|
46 | |
---|
47 | |
---|
48 | |
---|
49 | 3) Make user _xymon part of the admin group: |
---|
50 | ---------------------------------------------- |
---|
51 | |
---|
52 | We achieve this with the Directory Service command line utility: |
---|
53 | $ sudo dscl . -append /Groups/admin GroupMembership _xymon |
---|
54 | |
---|
55 | |
---|
56 | |
---|
57 | |
---|
58 | 4) Start Xymon server |
---|
59 | ---------------------------------------------- |
---|
60 | |
---|
61 | A startup item has been generated that will aid in |
---|
62 | starting xymon with launchd. It is disabled |
---|
63 | by default. Execute the following command to start it, |
---|
64 | and to cause it to launch at startup: |
---|
65 | |
---|
66 | $ sudo launchctl load -w /Library/LaunchDaemons/org.macports.xymon-server.plist |
---|
67 | |
---|
68 | If your Mac OSX firewall is enabled, you'll be asked to allow |
---|
69 | xymon -> accept |
---|
70 | On Mac OSX Server, make sure your ipfw rules will allow |
---|
71 | incoming TCP connections to port 1984 |
---|
72 | |
---|
73 | |
---|
74 | 5) check the status of your Xymon server |
---|
75 | ---------------------------------------------- |
---|
76 | |
---|
77 | To view the Xymon webpages, go to http://localhost/xymon |
---|
78 | |
---|
79 | ---------------------------------------------- |
---|
80 | |
---|
81 | |
---|
82 | |
---|
83 | |
---|
84 | *** Quick start for the impatient *** |
---|
85 | |
---|
86 | Run the following commands in your terminal: |
---|
87 | $ sudo echo \"kern.sysv.shmmni=64\" >> /etc/sysctl.conf |
---|
88 | $ sudo echo \"kern.sysv.shmseg=12\" >> /etc/sysctl.conf |
---|
89 | $ sudo mv ${prefix}/lib/xymon/server/etc/hobbit-apache.conf /etc/apache2/sites/ |
---|
90 | $ sudo /usr/sbin/apachectl restart |
---|
91 | $ sudo dscl . -append /Groups/admin GroupMembership _xymon |
---|
92 | Reboot your system |
---|
93 | $ sudo launchctl load -w /Library/LaunchDaemons/org.macports.xymon-server.plist |
---|
94 | Open http://localhost/xymon in your server's browser |
---|
95 | |
---|
96 | " |
---|